Symptom

The backup service is shut down during a backup or an Insight scan, and the following warnings are presented:

WARN : 19:03:41 Non Daemon Thread pool-1-thread-1 still active. Interrupting...
 WARN : 19:03:41 Non Daemon Thread HttpClient@7bc52ba7-46 still active. Interrupting...
  WARN : 19:03:45 Non Daemon Thread HttpClient@7bc52ba7-scheduler-1 still active. Interrupting...
 

Cause

This can be caused by antivirus software, an Agent update, or a scheduled reboot.

 

Solution

Check that the appropriate antivirus exclusions are in place, and check the Windows event logs to see if a reboot or service restart is visible there which could explain the shutdown.